import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "oz(3[4-9]|[4-9][0-9]|[1-9][0-9]{2}|[12][0-9]{3}|3[0-8][0-9]{2}|39[0-7][0-9]|398[0-2])";
final String string = "oz31 oz32 oz33 oz34 oz35 oz55 oz100 oz123 oz999 oz1000 oz2000 oz3000 oz3981 oz3982 oz3983";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}