using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"oz(3[4-9]|[4-9][0-9]|[1-9][0-9]{2}|[12][0-9]{3}|3[0-8][0-9]{2}|39[0-7][0-9]|398[0-2])";
string input = @"oz31 oz32 oz33 oz34 oz35 oz55 oz100 oz123 oz999 oz1000 oz2000 oz3000 oz3981 oz3982 oz3983";
foreach (Match m in Regex.Matches(input, pattern))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}