re = /^(?:.*) (?:access-group)(.*)(?:in)(?:\n)(?:.*)(?:access-group)(.*)(?:out)/m
str = 'interface Vlan100
description NAME
ip address 10.0.0.1 255.255.255.0
ip helper-address 111.111.1.1
ip access-group IN_ACL in
ip access-group OUT_ACL out'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end