import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?:.*) (?:access-group)(.*)(?:in)(?:\\n)(?:.*)(?:access-group)(.*)(?:out)";
final String string = "interface Vlan100\n"
+ "description NAME\n"
+ "ip address 10.0.0.1 255.255.255.0\n"
+ "ip helper-address 111.111.1.1\n"
+ "ip access-group IN_ACL in\n"
+ "ip access-group OUT_ACL out";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}