package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(?:.*) (?:access-group)(.*)(?:in)(?:\n)(?:.*)(?:access-group)(.*)(?:out)`)
var str = `interface Vlan100
description NAME
ip address 10.0.0.1 255.255.255.0
ip helper-address 111.111.1.1
ip access-group IN_ACL in
ip access-group OUT_ACL out`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}