#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?:.*) (?:access-group)(.*)(?:in)(?:\n)(?:.*)(?:access-group)(.*)(?:out)"
Local $sString = "interface Vlan100" & @CRLF & _
"description NAME" & @CRLF & _
"ip address 10.0.0.1 255.255.255.0" & @CRLF & _
"ip helper-address 111.111.1.1" & @CRLF & _
"ip access-group IN_ACL in" & @CRLF & _
"ip access-group OUT_ACL out"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")