$re = '/\W*de\W+(\w+)\W+(\d{1,2}h\d{0,2})\W+à\W+(\w+)\W+(\d{1,2}h\d{0,2})\W*:\W*\+(\d+)(h|h00|:00|j)/m';
$str = 'de lundi 12h à mardi 13h30 : +12h,de dimanche 0h à lundi 6h30:+24h, de mardi 0h à mardi 23h : +2j';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);