use strict;
my $str = 'de lundi 12h à mardi 13h30 : +12h,de dimanche 0h à lundi 6h30:+24h, de mardi 0h à mardi 23h : +2j';
my $regex = qr/\W*de\W+(\w+)\W+(\d{1,2}h\d{0,2})\W+à\W+(\w+)\W+(\d{1,2}h\d{0,2})\W*:\W*\+(\d+)(h|h00|:00|j)/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}