#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)\W*de\W+(\w+)\W+(\d{1,2}h\d{0,2})\W+à\W+(\w+)\W+(\d{1,2}h\d{0,2})\W*:\W*\+(\d+)(h|h00|:00|j)"
Local $sString = "de lundi 12h à mardi 13h30 : +12h,de dimanche 0h à lundi 6h30:+24h, de mardi 0h à mardi 23h : +2j"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")