const regex = /\W*de\W+(\w+)\W+(\d{1,2}h\d{0,2})\W+à\W+(\w+)\W+(\d{1,2}h\d{0,2})\W*:\W*\+(\d+)(h|h00|:00|j)/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('\\W*de\\W+(\\w+)\\W+(\\d{1,2}h\\d{0,2})\\W+à\\W+(\\w+)\\W+(\\d{1,2}h\\d{0,2})\\W*:\\W*\\+(\\d+)(h|h00|:00|j)', 'gm')
const str = `de lundi 12h à mardi 13h30 : +12h,de dimanche 0h à lundi 6h30:+24h, de mardi 0h à mardi 23h : +2j`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}