import Foundation
let pattern = #"^(\((\d{3})\)|(\d{3}))[\s\-\.]?\d{3}[\s\-\.]?\d{4}"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = ##"""
678 9o2 65o1
33 43 269413
(716)5 262238
(334)7 21-0630
256-462-6615
256 462 6615
72 47 36 7976
(681)2 433259
256-462-6615
7✴two✴0✴six✴four✴nine✴2✴zero✴7✴eight
(302)4 872364
678 NO TROUBLE NO GAMES 964 RLEAXIN SPACE JUST TO GET AWAY Wettness your taste buds needs 0656
2❤#TWO 0❤ZERO5 ❤FIVE 5❤FIVE 2❤TWO 6❤SIX 8❤EIGHTY 7❤SEVEN 1❤ONE SIX 6
720/838/8032
"""##
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)