const regex = /^(\((\d{3})\)|(\d{3}))[\s\-\.]?\d{3}[\s\-\.]?\d{4}/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^(\\((\\d{3})\\)|(\\d{3}))[\\s\\-\\.]?\\d{3}[\\s\\-\\.]?\\d{4}', 'gm')
const str = `678 9o2 65o1
33 43 269413
(716)5 262238
(334)7 21-0630
256-462-6615
256 462 6615
72 47 36 7976
(681)2 433259
256-462-6615
7✴two✴0✴six✴four✴nine✴2✴zero✴7✴eight
(302)4 872364
678 NO TROUBLE NO GAMES 964 RLEAXIN SPACE JUST TO GET AWAY Wettness your taste buds needs 0656
2❤#TWO 0❤ZERO5 ❤FIVE 5❤FIVE 2❤TWO 6❤SIX 8❤EIGHTY 7❤SEVEN 1❤ONE SIX 6
720/838/8032`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}