$re = '/^(\((\d{3})\)|(\d{3}))[\s\-\.]?\d{3}[\s\-\.]?\d{4}/m';
$str = '678 9o2 65o1
33 43 269413
(716)5 262238
(334)7 21-0630
256-462-6615
256 462 6615
72 47 36 7976
(681)2 433259
256-462-6615
7✴two✴0✴six✴four✴nine✴2✴zero✴7✴eight
(302)4 872364
678 NO TROUBLE NO GAMES 964 RLEAXIN SPACE JUST TO GET AWAY Wettness your taste buds needs 0656
2❤#TWO 0❤ZERO5 ❤FIVE 5❤FIVE 2❤TWO 6❤SIX 8❤EIGHTY 7❤SEVEN 1❤ONE SIX 6
720/838/8032';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);