import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(\\((\\d{3})\\)|(\\d{3}))[\\s\\-\\.]?\\d{3}[\\s\\-\\.]?\\d{4}";
final String string = "678 9o2 65o1\n"
+ "33 43 269413\n"
+ "(716)5 262238\n"
+ "(334)7 21-0630\n"
+ "256-462-6615\n"
+ "256 462 6615\n"
+ "72 47 36 7976\n"
+ "(681)2 433259\n"
+ "256-462-6615\n"
+ "7✴two✴0✴six✴four✴nine✴2✴zero✴7✴eight\n"
+ "(302)4 872364\n\n"
+ "678 NO TROUBLE NO GAMES 964 RLEAXIN SPACE JUST TO GET AWAY Wettness your taste buds needs 0656\n\n"
+ "2❤#TWO 0❤ZERO5 ❤FIVE 5❤FIVE 2❤TWO 6❤SIX 8❤EIGHTY 7❤SEVEN 1❤ONE SIX 6\n\n"
+ "720/838/8032";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}