$re = '/^\([\d_]{3}\)[\d_]{3}-[\d_]{2}-[\d_]{2}$/';
$str = '(581)451-11-15';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);