package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`^\([\d_]{3}\)[\d_]{3}-[\d_]{2}-[\d_]{2}$`)
var str = `(581)451-11-15`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}