const regex = /^\([\d_]{3}\)[\d_]{3}-[\d_]{2}-[\d_]{2}$/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^\\([\\d_]{3}\\)[\\d_]{3}-[\\d_]{2}-[\\d_]{2}$', '')
const str = `(581)451-11-15`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}