using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^\([\d_]{3}\)[\d_]{3}-[\d_]{2}-[\d_]{2}$";
string input = @"(581)451-11-15";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}