import Foundation
let pattern = #"(https?:\/\/)?(www\.)?youtu\.?be(\.com\/watch\?v=)?\/?"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
https://www.youtube.com/watch?v=a54d65asd45a6sd4
http://www.youtube.com/watch?v=aldkjalksdj1203
www.youtube.com/watch?v=
youtube.com/watch?v=
https://youtu.be/asdas123123
http://youtu.be/asdas123123
youtu.be/lakdjklj123
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)