// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(https?:\/\/)?(www\.)?youtu\.?be(\.com\/watch\?v=)?\/?").unwrap();
let string = "https://www.youtube.com/watch?v=a54d65asd45a6sd4
http://www.youtube.com/watch?v=aldkjalksdj1203
www.youtube.com/watch?v=
youtube.com/watch?v=
https://youtu.be/asdas123123
http://youtu.be/asdas123123
youtu.be/lakdjklj123";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}