package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(https?:\/\/)?(www\.)?youtu\.?be(\.com\/watch\?v=)?\/?`)
var str = `https://www.youtube.com/watch?v=a54d65asd45a6sd4
http://www.youtube.com/watch?v=aldkjalksdj1203
www.youtube.com/watch?v=
youtube.com/watch?v=
https://youtu.be/asdas123123
http://youtu.be/asdas123123
youtu.be/lakdjklj123`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}