re = /(https?:\/\/)?(www\.)?youtu\.?be(\.com\/watch\?v=)?\/?/
str = 'https://www.youtube.com/watch?v=a54d65asd45a6sd4
http://www.youtube.com/watch?v=aldkjalksdj1203
www.youtube.com/watch?v=
youtube.com/watch?v=
https://youtu.be/asdas123123
http://youtu.be/asdas123123
youtu.be/lakdjklj123'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end