$re = '/^port:[0-9]*$/';
$str = 'Port78
P67
Port87w
78
';
preg_match($re, $str, $matches, PREG_OFFSET_CAPTURE, 0);
// Print the entire match result
var_dump($matches);