const regex = /^port:[0-9]*$/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^port:[0-9]*$', '')
const str = `Port78
P67
Port87w
78
`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
if ((m = regex.exec(str)) !== null) {
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}