package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`^port:[0-9]*$`)
var str = `Port78
P67
Port87w
78
`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}