using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"^port:[0-9]*$";
string input = @"Port78
P67
Port87w
78
";
Match m = Regex.Match(input, pattern);
Console.WriteLine("'{0}' found at index {1}", m.Value, m.Index);
}
}