re = /^\bhttps\b.*?\b-cat.\b\d+./m
str = 'https://shopee.vn/%C4%90%E1%BB%93ng-H%E1%BB%93-Nam-cat.11035788.11035789'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end