package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^\bhttps\b.*?\b-cat.\b\d+.`)
var str = `https://shopee.vn/%C4%90%E1%BB%93ng-H%E1%BB%93-Nam-cat.11035788.11035789`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}