$re = '/^\bhttps\b.*?\b-cat.\b\d+./m';
$str = 'https://shopee.vn/%C4%90%E1%BB%93ng-H%E1%BB%93-Nam-cat.11035788.11035789';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);