const regex = /^\bhttps\b.*?\b-cat.\b\d+./gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('^\\bhttps\\b.*?\\b-cat.\\b\\d+.', 'gm')
const str = `https://shopee.vn/%C4%90%E1%BB%93ng-H%E1%BB%93-Nam-cat.11035788.11035789`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}