# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"""
facebook\.com\/
[^\s?]+
(?:
\.(\d+)\/(\d+)
\S*
|
\?
# Look for 'story_fbid' and 'id' in any order
(?=(?:[^\s&]*?&)*?\bstory_fbid=(\d+))
(?=(?:[^\s&]*?&)*?\bid=(\d+))
\S*
)
"""
test_str = ("https://www.facebook.com/102414276572175/photos/a.102567829890153.221.102414276572175/460475714099361/?type=3&theater\n"
"https://www.facebook.com/102414276572175/photos/a.102567829890153.221.102414276572175/454158281397771/?type=3&theater\n"
"https://www.facebook.com/102414276572175/photos/a.102567829890153.221.102414276572175/454158281397771\n"
"https://www.facebook.com/permalink.php?story_fbid=460713274075605&id=102414276572175\n"
"https://facebook.com/permalink.php?story_fbid=460713274075605&id=102414276572175\n"
"https://facebook.com/permalink.php?id=102414276572175&story_fbid=460713274075605\n\n"
"1.102414276572175\n"
"2.460475714099361")
matches = re.finditer(regex, test_str, re.MULTILINE | re.VERBOSE)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.