#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?mx)facebook\.com\/" & @CRLF & _
"[^\s?]+" & @CRLF & _
"(?:" & @CRLF & _
" \.(\d+)\/(\d+)" & @CRLF & _
" \S*" & @CRLF & _
"|" & @CRLF & _
" \?" & @CRLF & _
" # Look for 'story_fbid' and 'id' in any order" & @CRLF & _
" (?=(?:[^\s&]*?&)*?\bstory_fbid=(\d+))" & @CRLF & _
" (?=(?:[^\s&]*?&)*?\bid=(\d+))" & @CRLF & _
" \S*" & @CRLF & _
")"
Local $sString = "https://www.facebook.com/102414276572175/photos/a.102567829890153.221.102414276572175/460475714099361/?type=3&theater" & @CRLF & _
"https://www.facebook.com/102414276572175/photos/a.102567829890153.221.102414276572175/454158281397771/?type=3&theater" & @CRLF & _
"https://www.facebook.com/102414276572175/photos/a.102567829890153.221.102414276572175/454158281397771" & @CRLF & _
"https://www.facebook.com/permalink.php?story_fbid=460713274075605&id=102414276572175" & @CRLF & _
"https://facebook.com/permalink.php?story_fbid=460713274075605&id=102414276572175" & @CRLF & _
"https://facebook.com/permalink.php?id=102414276572175&story_fbid=460713274075605" & @CRLF & _
"" & @CRLF & _
"1.102414276572175" & @CRLF & _
"2.460475714099361"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")