using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"facebook\.com\/
[^\s?]+
(?:
\.(\d+)\/(\d+)
\S*
|
\?
# Look for 'story_fbid' and 'id' in any order
(?=(?:[^\s&]*?&)*?\bstory_fbid=(\d+))
(?=(?:[^\s&]*?&)*?\bid=(\d+))
\S*
)";
string input = @"https://www.facebook.com/102414276572175/photos/a.102567829890153.221.102414276572175/460475714099361/?type=3&theater
https://www.facebook.com/102414276572175/photos/a.102567829890153.221.102414276572175/454158281397771/?type=3&theater
https://www.facebook.com/102414276572175/photos/a.102567829890153.221.102414276572175/454158281397771
https://www.facebook.com/permalink.php?story_fbid=460713274075605&id=102414276572175
https://facebook.com/permalink.php?story_fbid=460713274075605&id=102414276572175
https://facebook.com/permalink.php?id=102414276572175&story_fbid=460713274075605
1.102414276572175
2.460475714099361";
RegexOptions options = RegexOptions.Multiline | RegexOptions.IgnorePatternWhitespace;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}