use strict;
my $str = 'https://www.facebook.com/102414276572175/photos/a.102567829890153.221.102414276572175/460475714099361/?type=3&theater
https://www.facebook.com/102414276572175/photos/a.102567829890153.221.102414276572175/454158281397771/?type=3&theater
https://www.facebook.com/102414276572175/photos/a.102567829890153.221.102414276572175/454158281397771
https://www.facebook.com/permalink.php?story_fbid=460713274075605&id=102414276572175
https://facebook.com/permalink.php?story_fbid=460713274075605&id=102414276572175
https://facebook.com/permalink.php?id=102414276572175&story_fbid=460713274075605
1.102414276572175
2.460475714099361';
my $regex = qr/facebook\.com\/
[^\s?]+
(?:
\.(\d+)\/(\d+)
\S*
|
\?
# Look for 'story_fbid' and 'id' in any order
(?=(?:[^\s&]*?&)*?\bstory_fbid=(\d+))
(?=(?:[^\s&]*?&)*?\bid=(\d+))
\S*
)/mxp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}