re = /(?<elIf>#elif\((?<elIfContents>[^\)]+)\)(?<elIfResult>[\s\S]+?(?=#elif|#end)))/i
str = 'Note: the #end should be added to the result of the ifelse group in part 1
#elif(#C.Length >= 1.9m)
Tall boi
#elif(#C.Name == bob)
Hi bob
#end
#elif(#C.Length >= 1.9m)Tall boi#elif(#C.Name == bob)Hi bob#end'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end