using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(?<elIf>#elif\((?<elIfContents>[^\)]+)\)(?<elIfResult>[\s\S]+?(?=#elif|#end)))";
string input = @"Note: the #end should be added to the result of the ifelse group in part 1
#elif(#C.Length >= 1.9m)
Tall boi
#elif(#C.Name == bob)
Hi bob
#end
#elif(#C.Length >= 1.9m)Tall boi#elif(#C.Name == bob)Hi bob#end";
RegexOptions options = RegexOptions.IgnoreCase;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}