$re = '/(?<elIf>#elif\((?<elIfContents>[^\)]+)\)(?<elIfResult>[\s\S]+?(?=#elif|#end)))/i';
$str = 'Note: the #end should be added to the result of the ifelse group in part 1
#elif(#C.Length >= 1.9m)
Tall boi
#elif(#C.Name == bob)
Hi bob
#end
#elif(#C.Length >= 1.9m)Tall boi#elif(#C.Name == bob)Hi bob#end';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);