#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?i)(?<elIf>#elif\((?<elIfContents>[^\)]+)\)(?<elIfResult>[\s\S]+?(?=#elif|#end)))"
Local $sString = "Note: the #end should be added to the result of the ifelse group in part 1" & @CRLF & _
"" & @CRLF & _
" #elif(#C.Length >= 1.9m)" & @CRLF & _
" Tall boi" & @CRLF & _
" #elif(#C.Name == bob)" & @CRLF & _
" Hi bob" & @CRLF & _
" #end" & @CRLF & _
"" & @CRLF & _
"#elif(#C.Length >= 1.9m)Tall boi#elif(#C.Name == bob)Hi bob#end"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")