import Foundation
let pattern = #"^127\.\d{1,3}\.\d{1,3}\.\d{1,3}(\:\d+)?$"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
127.1.1.1:4000
127.12.12.12
127.0.0.2:599595
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
if let firstMatch = regex.firstMatch(in: testString, range: stringRange) {
let result: [String] = (1 ..< firstMatch.numberOfRanges).map { (testString as NSString).substring(with: firstMatch.range(at: $0)) }
print(result)
} else {
print("No matches were found.")
}