import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^127\\.\\d{1,3}\\.\\d{1,3}\\.\\d{1,3}(\\:\\d+)?$";
final String string = "127.1.1.1:4000\n"
+ "127.12.12.12\n"
+ "127.0.0.2:599595\n\n\n\n";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
if (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}