#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "^127\.\d{1,3}\.\d{1,3}\.\d{1,3}(\:\d+)?$"
Local $sString = "127.1.1.1:4000" & @CRLF & _
"127.12.12.12" & @CRLF & _
"127.0.0.2:599595" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
"" & @CRLF & _
""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYFULLMATCH)
; Present the entire match result
_ArrayDisplay($aArray, "Result")