package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`^127\.\d{1,3}\.\d{1,3}\.\d{1,3}(\:\d+)?$`)
var str = `127.1.1.1:4000
127.12.12.12
127.0.0.2:599595
`
if len(re.FindStringIndex(str)) > 0 {
fmt.Println(re.FindString(str),"found at index",re.FindStringIndex(str)[0])
}
}