// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?i)(<p.*?>.*?<\/p>)").unwrap();
let string = "<p class=\"p\">test</p>";
let substitution = " ";
// result will be a String with the substituted value
let result = regex.replace(string, substitution);
println!("{}", result);
}