# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/(<p.*?>.*?<\\/p>)/ /i;t' <<< "<p class=\"p\">test</p>"