const regex = /(<p.*?>.*?<\/p>)/i;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(<p.*?>.*?<\\\/p>)', 'i')
const str = `<p class="p">test</p>`;
const subst = ` `;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);