import Foundation
let pattern = #"(?:((\babstract\b\s)?)(T\s|\w+<?\w+<?\w+>?>?\s)(\w+<T>|[a-zA-Z0-9]+)(\(.*\))(\s=>\s\w+)?)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
public void Something();
public List<int> SomethingElse();
private List<string> SomethingElseElse(One one);
private IEnumerable<List<string> Crazy(One one, Two two);
private IEnumerable<List<string> Crazy(One one, Two two) => AndSoOn;
public abstract void Run();
public T Get<T>(params object[] args)
private void rfrmBusyScreen_Load(object sender, EventArgs e)
public void Generate24HourSchedule(List<ScheduledEntry> scheduled)
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)