use strict;
my $str = 'public void Something();
public List<int> SomethingElse();
private List<string> SomethingElseElse(One one);
private IEnumerable<List<string> Crazy(One one, Two two);
private IEnumerable<List<string> Crazy(One one, Two two) => AndSoOn;
public abstract void Run();
public T Get<T>(params object[] args)
private void rfrmBusyScreen_Load(object sender, EventArgs e)
public void Generate24HourSchedule(List<ScheduledEntry> scheduled)';
my $regex = qr/(?:((\babstract\b\s)?)(T\s|\w+<?\w+<?\w+>?>?\s)(\w+<T>|[a-zA-Z0-9]+)(\(.*\))(\s=>\s\w+)?)/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}