// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?:((\babstract\b\s)?)(T\s|\w+<?\w+<?\w+>?>?\s)(\w+<T>|[a-zA-Z0-9]+)(\(.*\))(\s=>\s\w+)?)").unwrap();
let string = "public void Something();
public List<int> SomethingElse();
private List<string> SomethingElseElse(One one);
private IEnumerable<List<string> Crazy(One one, Two two);
private IEnumerable<List<string> Crazy(One one, Two two) => AndSoOn;
public abstract void Run();
public T Get<T>(params object[] args)
private void rfrmBusyScreen_Load(object sender, EventArgs e)
public void Generate24HourSchedule(List<ScheduledEntry> scheduled)";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}