re = /(?:((\babstract\b\s)?)(T\s|\w+<?\w+<?\w+>?>?\s)(\w+<T>|[a-zA-Z0-9]+)(\(.*\))(\s=>\s\w+)?)/
str = 'public void Something();
public List<int> SomethingElse();
private List<string> SomethingElseElse(One one);
private IEnumerable<List<string> Crazy(One one, Two two);
private IEnumerable<List<string> Crazy(One one, Two two) => AndSoOn;
public abstract void Run();
public T Get<T>(params object[] args)
private void rfrmBusyScreen_Load(object sender, EventArgs e)
public void Generate24HourSchedule(List<ScheduledEntry> scheduled)'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end