use strict;
my $str = 'int i;
String s;
public int go = 23; sdfsdfsdfsdf
public static final int value,valu2;
public static final String t,t1,t2 = 23;
String myString="25";';
my $regex = qr/^((?:\w+)[^=;]+)=?\s*([^;]+)/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}